On Tue, 29 Sept 2026 at 22:21, Colton Lewis <[email protected]> wrote:
>
> Hi Peter,
>
> Thanks for reviewing!
>
> On Mon, Sep 28, 2026 at 03:01:32PM +0100, Peter Maydell wrote:
> > What should we do with these properties if we're not using KVM
> > (i.e. for TCG, hvf, etc) ?
>
> PMU partitioning is specific to KVM, so moving it into
> kvm_arm_add_vcpu_properties() (which is only called when kvm_enabled())
> and naming it "kvm-pmu-partition" per the KVM VCPU Features convention
> in docs/system/arm/cpu-features.rst seems to make the most sense.
>
> For the counter limit property, would you prefer that it also live in
> kvm_arm_add_vcpu_properties() as "kvm-pmu-num-counters" (KVM-only), or
> keep "pmu-num-counters" general so TCG can also use it to override
> PMCR_EL0.N in reset_pmcr_el0?

If it can reasonably easily be implemented (or potentially implemented)
for TCG, then I guess the general name makes most sense.

-- PMM

Reply via email to