This addresses various points raised by Markus about the current impl/design, that would need to be addressed before this is included in the release.
NB, the 'warn' option will repeatedly warn on every violation which can be somewhat unpleasant. Figuring out a mechanism to make it a one-time warning is an exercise for the future, given limited time before release. Changed in v2: * Expand docs to state 'warn' occurs repeatedly * Various docs rephrasing changes * Add error hint for security check Daniel P. Berrangé (8): qapi: make 'CompatPolicy' the first arg in compat_policy_input_ok qapi: add 'warn' option to CompatPolicyInput qapi: rename 'insecure-types' to 'insecure-input' qapi: drop CompatPolicySecurity and use CompatPolicyInput qapi: rename compat_policy_check_security method qapi: reverse arg order in compat_policy_security_ok qemu-options: document -compat insecure-input parameter qapi: print a message before aborting for -compat violations docs/system/security.rst | 2 +- include/qapi/compat-policy.h | 12 ++++---- qapi/compat.json | 27 +++++------------ qapi/qapi-util.c | 57 +++++++++++++++++++----------------- qapi/qapi-visit-core.c | 4 +-- qapi/qmp-dispatch.c | 2 +- qapi/qobject-input-visitor.c | 2 +- qemu-options.hx | 37 +++++++++++++++++++---- qom/object.c | 8 ++--- 9 files changed, 85 insertions(+), 66 deletions(-) -- 2.56.0
