On 08/20/2012 11:55 AM, Jan Kiszka wrote:
> No need to expose the fd-based interface, everyone will already be fine
> with the more handy EventNotifier variant. Rename the latter to clarify
> that we are still talking about irqfds here.

Thanks, applied.

>  
> -int kvm_irqchip_add_irqfd(KVMState *s, int fd, int virq);
> -int kvm_irqchip_remove_irqfd(KVMState *s, int fd, int virq);
> -int kvm_irqchip_add_irq_notifier(KVMState *s, EventNotifier *n, int virq);
> -int kvm_irqchip_remove_irq_notifier(KVMState *s, EventNotifier *n, int virq);
> +int kvm_irqchip_add_irqfd_notifier(KVMState *s, EventNotifier *n, int virq);
> +int kvm_irqchip_remove_irqfd_notifier(KVMState *s, EventNotifier *n, int 
> virq);
>  #endif

Those names aren't particularly satisfying.  add_irqfd_notifier implies
you want to be notified about irqfd events, but that's not what the
function does.  Not sure what a good name would be.


-- 
error compiling committee.c: too many arguments to function

Reply via email to