All looks good. Reviewed-by: Alon Levy <al...@redhat.com>
----- Original Message ----- > This series reworks the post_load code recently introduced to > allocate > the structures only when required (i.e. only at load time). This > helps keep the VirtIOSerial struct clean, and use less RAM. > > Also rearrange the code in virtio_serial_load() for easier > readability. > > Patch 4 fixes a race with the timer going off after a device got > hot-unplugged, and patch 1 uses unsigned int (uint32_t) type to count > ports, as in the rest of the code. > > Please review. > > Amit Shah (4): > virtio-serial: use uint32_t to count ports > virtio-serial: move active ports loading to separate function > virtio-serial: allocate post_load only at load-time > virtio-serial: delete timer if active during exit > > hw/virtio-serial-bus.c | 150 > +++++++++++++++++++++++++++++-------------------- > 1 file changed, 89 insertions(+), 61 deletions(-) > > -- > 1.8.0.2 > >