On Mon, May 13, 2013 at 09:20:08PM +0100, Peter Maydell wrote: > On 13 May 2013 21:01, Michael S. Tsirkin <m...@redhat.com> wrote: > > Sometimes we need to pass ranges around, add a > > handy structure for this purpose. > > > > Signed-off-by: Michael S. Tsirkin <m...@redhat.com> > > --- > > include/qemu/range.h | 22 ++++++++++++++++++++++ > > 1 file changed, 22 insertions(+) > > > > diff --git a/include/qemu/range.h b/include/qemu/range.h > > index 3502372..4bcd346 100644 > > --- a/include/qemu/range.h > > +++ b/include/qemu/range.h > > @@ -1,6 +1,28 @@ > > #ifndef QEMU_RANGE_H > > #define QEMU_RANGE_H > > > > +#include <inttypes.h> > > + > > +/* > > + * Operations on 64 address ranges. > > missing "bit" ? > > > + * Notes: > > + * - ranges must not wrap around 0, but can include the last byte ~0x0LL. > > + * - this can not represent a full 0 to ~0x0LL range. > > + */ > > + > > +/* A structure representing a range of addresses. */ > > +struct Range { > > + uint64_t begin; /* First byte of the range, or 0 if empty. */ > > + uint64_t end; /* 1 + the last byte. 0 if range empty or ends at > > ~0x0LL. */ > > +}; > > +typedef struct Range Range; > > + > > +/* verify that range is not empty and does not overlap */ > > Doesn't overlap what?
I meant wrap around there. > Why isn't an empty range valid? > The struct definition above says it's OK. Yes it's a bad name. Should be range_non_empty or something. > > +{ > > + return range->begin + 1 <= range->end; > > +} > > I note that memory.c defines its own concept of an AddrRange. > > thanks > -- PMM Good point, maybe I'll reuse that or just use two 64 bit fields explicitly. -- MST