On Tue, Mar 11, 2014 at 06:58:52PM +0800, chen.fan.fnst wrote:
> From: "chen.fan.fnst" <chen.fan.f...@cn.fujitsu.com>
> 
> Signed-off-by: Chen Fan <chen.fan.f...@cn.fujitsu.com>
> ---
>  target-i386/topology.h | 33 +++++++++++++++++----------------
>  1 file changed, 17 insertions(+), 16 deletions(-)
> 
> diff --git a/target-i386/topology.h b/target-i386/topology.h
> index 07a6c5f..7843976 100644
> --- a/target-i386/topology.h
> +++ b/target-i386/topology.h
> @@ -47,6 +47,12 @@
>   */
>  typedef uint32_t apic_id_t;
>  
> +typedef struct CpuTopoInfo {
> +    unsigned pkg_id;
> +    unsigned core_id;
> +    unsigned smt_id;
> +} CpuTopoInfo;

I suggest naming it "CPUTopoInfo". Maybe "X86CPUTopoInfo", to indicate
it is x86-specific.

The rest of the patch looks good.

-- 
Eduardo

Reply via email to