Am 19.03.2014 08:58, schrieb Stefan Hajnoczi: > The path resolution logic in object_property_set_link() should be a > separate function. This makes the code easier to read and maintain. > > Signed-off-by: Stefan Hajnoczi <stefa...@redhat.com> > --- > qom/object.c | 59 +++++++++++++++++++++++++++++++++++++++-------------------- > 1 file changed, 39 insertions(+), 20 deletions(-) > > diff --git a/qom/object.c b/qom/object.c > index a2a1ffa..da49474 100644 > --- a/qom/object.c > +++ b/qom/object.c > @@ -1039,17 +1039,49 @@ static void object_get_link_property(Object *obj, > Visitor *v, void *opaque, > } > } > > +/* object_resolve_link:
I've taken the liberty to adopt the recommended style for non-header gtk-doc comments here, using a single /* rather than /** line. Andreas > + * > + * Lookup an object and ensure its type matches the link property type. This > + * is similar to object_resolve_path() except type verification against the > + * link property is performed. > + * > + * Returns: The matched object or NULL on path lookup failures. > + */ > +static Object *object_resolve_link(Object *obj, const char *name, > + const char *path, Error **errp) [snip] -- SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer; HRB 16746 AG Nürnberg