On 11/14/2014 06:06 AM, Max Reitz wrote:
> Add helper functions for getting and setting refcounts in a refcount
> array for any possible refcount order, and choose the correct one during
> refcount initialization.
> 
> Signed-off-by: Max Reitz <mre...@redhat.com>
> ---
>  block/qcow2-refcount.c | 146 
> ++++++++++++++++++++++++++++++++++++++++++++++++-
>  1 file changed, 144 insertions(+), 2 deletions(-)
> 

> 
> +static void get_refcount_functions(int refcount_order,
> +                                   Qcow2GetRefcountFunc **get,
> +                                   Qcow2SetRefcountFunc **set)
> +{
> +    switch (refcount_order) {
> +        case 0:
> +            *get = &get_refcount_ro0;
> +            *set = &set_refcount_ro0;
> +            break;

Bike-shedding: instead of a switch statement and open-coded assignments,
is it worth setting up an array of function pointers where you just grab
the correct functions by doing array[refcount_order]?  But I don't see
any strong reason to change style; what you have works.

Reviewed-by: Eric Blake <ebl...@redhat.com>

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to