On 10.12.2014 08:48, Fam Zheng wrote:
On Tue, 12/09 17:26, Peter Lieven wrote:
diff --git a/include/hw/virtio/virtio-blk.h b/include/hw/virtio/virtio-blk.h
index 3f2652f..0ee9582 100644
--- a/include/hw/virtio/virtio-blk.h
+++ b/include/hw/virtio/virtio-blk.h
@@ -134,13 +134,6 @@ typedef struct VirtIOBlock {
      struct VirtIOBlockDataPlane *dataplane;
  } VirtIOBlock;
-#define VIRTIO_BLK_MAX_MERGE_REQS 32
-
-typedef struct MultiReqBuffer {
-    BlockRequest        blkreq[VIRTIO_BLK_MAX_MERGE_REQS];
-    unsigned int        num_writes;
-} MultiReqBuffer;
-
  typedef struct VirtIOBlockReq {
      VirtIOBlock *dev;
      VirtQueueElement elem;
@@ -149,8 +142,21 @@ typedef struct VirtIOBlockReq {
      QEMUIOVector qiov;
      struct VirtIOBlockReq *next;
      BlockAcctCookie acct;
+    QEMUIOVector mr_qiov;
+    struct VirtIOBlockReq *mr_next;
  } VirtIOBlockReq;
+#define MAX_MERGE_REQS 32
Why do you need to rename this macro after introducing it in previous patch?

Right ;-)

This was the orgininal name and I changed it later in Patch 2 by request.

Waiting for other feedback in will change it in a next revision.

Peter

Reply via email to