On 2014-12-11 at 11:49, Gerd Hoffmann wrote:
Now that common event handling code is split off, we can move
over sdl_refresh to sdl2-2d.c, and rename it to sdl2_2d_refresh.

Signed-off-by: Gerd Hoffmann <kra...@redhat.com>
---
  include/ui/sdl2.h |  1 +
  ui/sdl2-2d.c      |  9 +++++++++
  ui/sdl2.c         | 10 +---------
  3 files changed, 11 insertions(+), 9 deletions(-)

diff --git a/include/ui/sdl2.h b/include/ui/sdl2.h
index 27b3132..9e9a92d 100644
--- a/include/ui/sdl2.h
+++ b/include/ui/sdl2.h
@@ -23,4 +23,5 @@ void sdl2_2d_update(DisplayChangeListener *dcl,
                      int x, int y, int w, int h);
  void sdl2_2d_switch(DisplayChangeListener *dcl,
                      DisplaySurface *new_surface);
+void sdl2_2d_refresh(DisplayChangeListener *dcl);
  void sdl2_2d_redraw(struct sdl2_console *scon);
diff --git a/ui/sdl2-2d.c b/ui/sdl2-2d.c
index 40a552c..9c60075 100644
--- a/ui/sdl2-2d.c
+++ b/ui/sdl2-2d.c
@@ -103,6 +103,15 @@ void sdl2_2d_switch(DisplayChangeListener *dcl,
      sdl2_2d_redraw(scon);
  }
+void sdl2_2d_refresh(DisplayChangeListener *dcl)
+{
+    struct sdl2_console *scon = container_of(dcl, struct sdl2_console, dcl);
+
+    assert(!scon->opengl);

This doesn't compile for me because this flag is not added by this series.

With this assertion moved to the OpenGL series:

Reviewed-by: Max Reitz <mre...@redhat.com>

Reply via email to