On Fri, 23 Jan 2015 10:03:03 +0200
"Michael S. Tsirkin" <m...@redhat.com> wrote:

> > +typedef enum {
> > +    NON_BLOCK,
> > +    PACKAGE,
> > +    EXT_PACKAGE,
> > +    BUFFER,
> > +    RES_TEMPLATE,
> > +} AcpiBlockFlags;
> 
> Please prefix values with ACPI_BUILD_ - don't pollute the
> global namespace.
Could we use AML_ prefix instead?

> Same elsewhere: add build_ to functions, and Build to types.
Same here i.e. s/acpi_/aml_/ prefix in API calls?

> 
> This makes it clear these are not Acpi spec types,
> but helpers to build Aml.
> 
> > +
> > +typedef struct AcpiAml {
> > +    GArray *buf;
> > +    uint8_t op;
> > +    AcpiBlockFlags block_flags;
> > +} AcpiAml;
> > +
> > +void aml_append(AcpiAml *parent_ctx, AcpiAml child);
> > +
> >  GArray *build_alloc_array(void);
> >  void build_free_array(GArray *array);
> >  void build_prepend_byte(GArray *array, uint8_t val);
> > -- 
> > 1.8.3.1
> 


Reply via email to