This cleans up some of the NUMA code: moves declarations to numa.h, rename some functions, and remove some existing code that was inside main().
Eduardo Habkost (7): numa: Move NUMA declarations from sysemu.h to numa.h vl.c: Remove unnecessary zero-initialization of NUMA globals numa: Move NUMA globals to numa.c numa: Make max_numa_nodeid static numa: Move QemuOpts parsing to set_numa_nodes() numa: Rename option parsing functions numa: Rename set_numa_modes() to numa_post_machine_init() hw/i386/pc.c | 1 + hw/mem/pc-dimm.c | 1 + hw/ppc/spapr.c | 1 + include/sysemu/numa.h | 24 ++++++++++++++++++++++++ include/sysemu/sysemu.h | 18 ------------------ monitor.c | 1 + numa.c | 20 ++++++++++++++++---- vl.c | 22 +++------------------- 8 files changed, 47 insertions(+), 41 deletions(-) create mode 100644 include/sysemu/numa.h -- 2.1.0