Fam Zheng <f...@redhat.com> writes:

> On Wed, 03/09 14:10, Peter Xu wrote:
>> Remove useless var "ret".
>> 
>> Signed-off-by: Peter Xu <pet...@redhat.com>
>> ---
>>  hw/usb/dev-mtp.c | 4 +---
>>  1 file changed, 1 insertion(+), 3 deletions(-)
>> 
>> diff --git a/hw/usb/dev-mtp.c b/hw/usb/dev-mtp.c
>> index cf63fd0..38cc4fc 100644
>> --- a/hw/usb/dev-mtp.c
>> +++ b/hw/usb/dev-mtp.c
>> @@ -719,10 +719,8 @@ static void usb_mtp_add_str(MTPData *data, const char 
>> *str)
>>  {
>>      uint32_t len = strlen(str)+1;
>>      wchar_t *wstr = g_malloc(sizeof(wchar_t) * len);
>> -    size_t ret;
>>  
>> -    ret = mbstowcs(wstr, str, len);
>> -    if (ret == -1) {
>> +    if (mbstowcs(wstr, str, len) == -1) {
>>          usb_mtp_add_wstr(data, L"Oops");
>>      } else {
>>          usb_mtp_add_wstr(data, wstr);
>> -- 
>> 2.4.3
>> 
>> 
>
> The old way has no problem, no need to clean up, IMO.

It's a very small readability improvement, but it's an improvement.  If
I was the maintainer, I'd take it.

Reply via email to