From: Sergey Fedorov <serge.f...@gmail.com> Unify the code of this function with tb_jmp_remove_from_list(). Making these functions similar improves their readability. Also this could be a step towards making this function thread-safe.
Signed-off-by: Sergey Fedorov <serge.f...@gmail.com> Signed-off-by: Sergey Fedorov <sergey.fedo...@linaro.org> Reviewed-by: Alex Bennée <alex.ben...@linaro.org> --- Changes in v2: * Tweaked a comment to better describe jmp_list_{next|first} usage * Eliminated duplicate dereference of 'ptb' in tb_jmp_unlink() translate-all.c | 21 +++++++++------------ 1 file changed, 9 insertions(+), 12 deletions(-) diff --git a/translate-all.c b/translate-all.c index ce609778c810..b09774b1768b 100644 --- a/translate-all.c +++ b/translate-all.c @@ -964,25 +964,22 @@ static inline void tb_reset_jump(TranslationBlock *tb, int n) /* remove any jumps to the TB */ static inline void tb_jmp_unlink(TranslationBlock *tb) { - uintptr_t tb1, tb2; + TranslationBlock *tb1; + uintptr_t *ptb, ntb; unsigned int n1; - tb1 = tb->jmp_list_first; + ptb = &tb->jmp_list_first; for (;;) { - TranslationBlock *tmp_tb; - n1 = tb1 & 3; + ntb = *ptb; + n1 = ntb & 3; + tb1 = (TranslationBlock *)(ntb & ~3); if (n1 == 2) { break; } - tmp_tb = (TranslationBlock *)(tb1 & ~3); - tb2 = tmp_tb->jmp_list_next[n1]; - tb_reset_jump(tmp_tb, n1); - tmp_tb->jmp_list_next[n1] = (uintptr_t)NULL; - tb1 = tb2; + tb_reset_jump(tb1, n1); + *ptb = tb1->jmp_list_next[n1]; + tb1->jmp_list_next[n1] = (uintptr_t)NULL; } - - assert(((uintptr_t)tb & 3) == 0); - tb->jmp_list_first = (uintptr_t)tb | 2; /* fail safe */ } /* invalidate one TB */ -- 2.8.1