On 05/12/2016 05:25 AM, Paolo Bonzini wrote:
> 
> 
> On 06/05/2016 18:26, Eric Blake wrote:
>> @@ -340,11 +338,12 @@ static void scsi_do_read(SCSIDiskReq *r, int ret)
>>          r->req.aiocb = dma_blk_read(s->qdev.conf.blk, r->req.sg, r->sector,
>>                                      scsi_dma_complete, r);
> 
> This is broken, it should be changed to an offset in the previous patch.
> 
> Please rename the function too, so that it is obvious that you have
> changed all callers.
> 
> How was this patch tested?

Sadly, my testing was limited to NBD use of the blk_ functions, then
compile testing and close audit of all other drivers, to limit the
changes to ONLY the blk_ calling conventions. That's why I kept sector
alignment in other calls (as you later noticed, that means
dma_blk_read() was unchanged in semantics).

Yes, there are more cleanups possible, such as altering things to a new
dma_blk_pread() with byte semantics, but I'm hoping that it can be done
on a per-driver basis by someone more familiar with how to test the
changes.  I also like the fact that my patches were done at the very
beginning of the 2.7 cycle to maximize testing.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to