Richard Henderson writes: > On 09/09/2016 06:03 AM, Lluís Vilanova wrote: >> -void gen_intermediate_code(CPUAlphaState *env, struct TranslationBlock *tb) >> +void gen_intermediate_code(CPUState *cpu, struct TranslationBlock *tb) >> { >> - AlphaCPU *cpu = alpha_env_get_cpu(env); >> - CPUState *cs = CPU(cpu); >> + CPUAlphaState *env = cpu->env_ptr;
> Why the variable renames? I.e. why CPUState *cpu instead of CPUState *cs? It's the naming convention used on almost all other generic code in QEMU. Cheers, Lluis