On 20.02.2017 22:58, Denis V. Lunev wrote:
On 02/20/2017 08:48 PM, Eric Blake wrote:
On 02/20/2017 12:21 PM, Denis V. Lunev wrote:
From: Anton Nefedov <anton.nefe...@virtuozzo.com>
Signed-off-by: Anton Nefedov <anton.nefe...@virtuozzo.com>
Signed-off-by: Denis V. Lunev <d...@openvz.org>
CC: Paolo Bonzini <pbonz...@redhat.com>
CC: Eric Blake <ebl...@redhat.com>
---
qapi-schema.json | 12 ++++++++++++
target/i386/cpu.c | 15 ++++++---------
vl.c | 12 ++++++------
3 files changed, 24 insertions(+), 15 deletions(-)
diff --git a/qapi-schema.json b/qapi-schema.json
index e9a6364..b142e15 100644
--- a/qapi-schema.json
+++ b/qapi-schema.json
@@ -5872,6 +5872,16 @@
'data': [ 'pause', 'poweroff' ] }
##
+# @GuestPanicInformationType:
+#
+# An enumeration of the guest panic information types
+#
+# Since: 2.9
+##
+{ 'enum': 'GuestPanicInformationType',
+ 'data': [ 'hyper-v'] }
Perhaps 'hyperv' is better? It's the difference between
GUEST_PANIC_INFORMATION_TYPE_HYPER_V and
GUEST_PANIC_INFORMATION_TYPE_HYPERV. But that's bikeshedding, so no need
to change it.
Must go into 2.9, so we aren't baking in bad API.
Reviewed-by: Eric Blake <ebl...@redhat.com>
We can you plain 'hv', like all command line options controlling
HyperV features.
Roman, Evgeniy, do you have any opinion on that?
In vmbus we've settled on using "hyperv-" prefixes for stuff related to
QAPI namespace and QOM objects' property names: "hyperv-synic",
"hyperv-sint-route", etc. We might as well stick to it.
Den