31.05.2017 19:55, Vladimir Sementsov-Ogievskiy wrote:
Rename
   nbd_wr_syncv -> nbd_rwv
   read_sync -> nbd_read
   read_sync_eof -> nbd_read_eof
   write_sync -> nbd_write
   drop_sync -> nbd_drop

1. nbd_ prefix
    read_sync and write_sync are already shared, so it is good to have a
    namespace prefix. drop_sync will be shared, and read_sync_eof is
    related to read_sync, so let's rename them all.

2. _sync suffix
    _sync is related to the fact, that nbd_wr_syncv doesn't return if
    write to socket returns EAGAIN. In first implementation nbd_wr_syncv

not bad to add here the following note in parentheses. Please add it in flight, if no more updates required for the series.
(was wr_sync in 7a5ca8648b)

    just loops while getting EAGAIN, current implementation yields in
    this case.
    Why to get rid of it:
    - it is normal for r/w functions to be synchronous, so having
      additional suffix for it looks redundant (contrariwise, we have
      _aio suffix for async functions)
    - _sync suffix in block layer is used when function does flush (so
      using it for other thing is confusing a bit)
    - keep function names short after adding nbd_ prefix

3. for nbd_wr_syncv let's use more common notation 'rw'

Signed-off-by: Vladimir Sementsov-Ogievskiy <vsement...@virtuozzo.com>
---

--
Best regards,
Vladimir

Reply via email to