Hi ----- Original Message ----- > On 10/10/2017 04:21 PM, Eduardo Habkost wrote: > > On Tue, Oct 10, 2017 at 12:56:18AM +0200, Marc-André Lureau wrote: > > [...] > >> -static inline TPMVersion tpm_get_version(void) > >> +static inline TPMIf *tpm_find(void) > >> { > >> -#ifdef CONFIG_TPM > >> - Object *obj = object_resolve_path_type("", TYPE_TPM_TIS, NULL); > >> + Object *obj = object_resolve_path_type("", TYPE_TPM_IF, NULL); > > Considering that tpm_crb_realizefn() will rely on tpm_find() > > returning NULL if there are multiple TPM devices, I suggest > > adding a "returns NULL unless there is exactly one TPM device" > > comment, just like fw_cfg_find() and find_vmgenid_dev() > > I wonder whether the function couldn't have a better name. > tpm_find_single() ? >
As Eduardo said, there is precedence in QEMU codebase (fw_cfg_find() and find_vmgenid_dev()) I don't think foo_find() is a bad name - it returns NULL if there are multiple foo, which makes sense imho. I'll add the missing comment though.