In this series, mainly rewrite the tcp packet comparison based on
the tcp sequence number instead of original method that compare the
packet based on the payload size.

v3:
  p1: merged the patch1 and patch2 from v2 
  p2: -merged the patch3 and patch4 from v2
      -implement the same process flow for tcp, udp and icmp

                                                [Zhang Chen]
v2:
  p1: a new patch
  p2: a new patch
  p3: -rename the fill_pkt_seq to fill_pkt_tcp_info
      -rename pdsize & hdsize to payload_size & header_size
      -reuse duplicated code
      -modified colo_packet_compare_common() to suit the tcp packet
       comparison instead of build a new function service for tcp.
      -add more comments for the 'max_ack'
                                                [Zhang Chen]

Cc: Zhang Chen <zhangc...@gmail.com>
Cc: Li Zhijian <lizhij...@cn.fujitsu.com>
Cc: Jason Wang <jasow...@redhat.com>

Mao Zhongyi (2):
  colo: modified the payload compare function
  colo: compare the packet based on the tcp sequence number

 net/colo-compare.c | 411 +++++++++++++++++++++++++++++++++--------------------
 net/colo.c         |   9 ++
 net/colo.h         |  15 ++
 net/trace-events   |   2 +-
 4 files changed, 284 insertions(+), 153 deletions(-)

-- 
2.9.4




Reply via email to