On Fri, Aug 17, 2018 at 09:33:33AM +0200, Thomas Huth wrote:
> While adding the object_initialize_child() function, Paolo suggested
> to rename the similar object_new_with_props() function accordingly:
> 
> http://marc.info/?i=e034610d-9a1d-a8a5-ee92-b2e3f0ba2...@redhat.com
> 
> This way it is more obvious that this function creates a new object
> as a child of another object.

I'd expect 'object_new_with_child' to be the same as 'object_new',
but with only 'parent' & 'id' args added, which isn't the case here.

If we want the full & consistent design then we should have

  object_new(typename)
  object_new_with_child(typename, parent, id)
  object_new_props(typename, ...)
  object_new_propv(typename, va_arg props)
  object_new_with_child_props(typename, parent, id, ...)
  object_new_with_child_propv(typename, parent, id, va_arg props)


Regards,
Daniel
-- 
|: https://berrange.com      -o-    https://www.flickr.com/photos/dberrange :|
|: https://libvirt.org         -o-            https://fstop138.berrange.com :|
|: https://entangle-photo.org    -o-    https://www.instagram.com/dberrange :|

Reply via email to