On Thu, Nov 22, 2018 at 01:35:05PM +0000, Peter Maydell wrote: > The API of cpu_physical_memory_write_rom() is odd, because it > takes an AddressSpace, unlike all the other cpu_physical_memory_* > access functions. We note this oddity as a TODO in the > docs/devel/loads-stores.rst documentation. > > Rename cpu_physical_memory_write_rom() to address_space_write_rom(), > and give it an API that matches address_space_write(). > We also adjest the cpu_physical_memory_write_rom_internal() > function which is local to exec.c similarly. > > thanks > -- PMM
Acked-by: Michael S. Tsirkin <m...@redhat.com> > Peter Maydell (2): > exec.c: Rename cpu_physical_memory_write_rom_internal() > Rename cpu_physical_memory_write_rom() to address_space_write_rom() > > include/exec/cpu-common.h | 2 -- > include/exec/memory.h | 26 ++++++++++++++++++++++++++ > exec.c | 30 +++++++++++++++++++----------- > hw/core/loader.c | 4 ++-- > hw/intc/apic.c | 7 ++++--- > hw/misc/tz-mpc.c | 2 +- > hw/sparc/sun4m.c | 5 +++-- > docs/devel/loads-stores.rst | 35 ++++++++++++++++------------------- > 8 files changed, 71 insertions(+), 40 deletions(-) > > -- > 2.19.1