On 7/31/19 9:56 AM, Thomas Huth wrote: > The "register" device is only used by certain machines. Let's add > a proper config switch for it so that it only gets compiled when we > really need it. > > Signed-off-by: Thomas Huth <th...@redhat.com> > --- > hw/Kconfig | 1 + > hw/core/Kconfig | 3 +++ > hw/core/Makefile.objs | 2 +- > hw/dma/Kconfig | 1 + > 4 files changed, 6 insertions(+), 1 deletion(-) > > diff --git a/hw/Kconfig b/hw/Kconfig > index dbae1c0852..b45db3c813 100644 > --- a/hw/Kconfig > +++ b/hw/Kconfig > @@ -76,3 +76,4 @@ config XILINX_AXI > > config XLNX_ZYNQMP > bool > + select REGISTER > diff --git a/hw/core/Kconfig b/hw/core/Kconfig > index c2a1ae8122..d11920fcb3 100644 > --- a/hw/core/Kconfig > +++ b/hw/core/Kconfig > @@ -9,3 +9,6 @@ config FITLOADER > > config PLATFORM_BUS > bool > + > +config REGISTER
What about naming it REGISTER_ARRAY or REGISTER_BLOCK? The API is: RegisterInfoArray *register_init_block32(...); Cc'ing Alistair for better name ideas :) > + bool > diff --git a/hw/core/Makefile.objs b/hw/core/Makefile.objs > index f8481d959f..d6cfb2a81b 100644 > --- a/hw/core/Makefile.objs > +++ b/hw/core/Makefile.objs > @@ -17,7 +17,7 @@ common-obj-$(CONFIG_SOFTMMU) += machine.o > common-obj-$(CONFIG_SOFTMMU) += loader.o > common-obj-$(CONFIG_FITLOADER) += loader-fit.o > common-obj-$(CONFIG_SOFTMMU) += qdev-properties-system.o > -common-obj-$(CONFIG_SOFTMMU) += register.o > +common-obj-$(CONFIG_REGISTER) += register.o > common-obj-$(CONFIG_SOFTMMU) += or-irq.o > common-obj-$(CONFIG_SOFTMMU) += split-irq.o > common-obj-$(CONFIG_PLATFORM_BUS) += platform-bus.o > diff --git a/hw/dma/Kconfig b/hw/dma/Kconfig > index 751dec5426..5c61b67bc0 100644 > --- a/hw/dma/Kconfig > +++ b/hw/dma/Kconfig > @@ -16,6 +16,7 @@ config I8257 > > config ZYNQ_DEVCFG > bool > + select REGISTER > > config STP2000 > bool >