Markus Armbruster <arm...@redhat.com> writes: > Vladimir Sementsov-Ogievskiy <vsement...@virtuozzo.com> writes: > >> Make qbus_list_bus and qbus_list_dev hint append helpers well formed: >> switch errp paramter to Error *const * type, as it has uncommon >> behavior: not change the pointer to return error, but operate on >> already existent error object. >> Rename functions to be error_append_*_hint. >> >> Signed-off-by: Vladimir Sementsov-Ogievskiy <vsement...@virtuozzo.com> > > "well form error hint helpers" tells me nothing. PATCH 03 does the same > (less function renames), and is titled "make Error **errp const where it > is appropriate". I like that better. No big deal, and certainly not > worth a respin by itself. I'm happy to touch up commit messages in my > tree.
Let's adapt PATCH 03's commit message, like this: qdev-monitor: make Error **errp const where it is appropriate Mostly, Error ** is for returning error from the function, so the callee sets it. However qbus_list_bus and qbus_list_dev get already filled errp parameter. They don't change the pointer itself, only change the internal state of referenced Error object. So we can make it Error *const * errp, to stress the behavior. It will also help coccinelle script (in future) to distinguish such cases from common errp usage. While there, rename the functions to qbus_error_append_bus_list_hint(), qbus_error_append_dev_list_hint(). With something like that: Reviewed-by: Markus Armbruster <arm...@redhat.com>