On Donnerstag, 9. Januar 2020 00:55:45 CET Greg Kurz wrote: > > diff --git a/tests/virtio-9p-test.c b/tests/virtio-9p-test.c > > index 06263edb53..48c0eca292 100644 > > --- a/tests/virtio-9p-test.c > > +++ b/tests/virtio-9p-test.c > > @@ -68,6 +68,11 @@ static void v9fs_memread(P9Req *req, void *addr, size_t > > len)> > > req->r_off += len; > > > > } > > > > +static void v9fs_uint8_read(P9Req *req, uint8_t *val) > > +{ > > + v9fs_memread(req, val, 1); > > +} > > + > > > > static void v9fs_uint16_write(P9Req *req, uint16_t val) > > { > > > > uint16_t le_val = cpu_to_le16(val); > > > > @@ -101,6 +106,12 @@ static void v9fs_uint32_read(P9Req *req, uint32_t > > *val)> > > le32_to_cpus(val); > > > > } > > > > +static void v9fs_uint64_read(P9Req *req, uint64_t *val) > > +{ > > + v9fs_memread(req, val, 8); > > + le64_to_cpus(val); > > +} > > + > > > > /* len[2] string[len] */ > > static uint16_t v9fs_string_size(const char *string) > > { > > > > @@ -191,6 +202,7 @@ static const char *rmessage_name(uint8_t id) > > > > id == P9_RLOPEN ? "RLOPEN" : > > id == P9_RWRITE ? "RWRITE" : > > > > id == P9_RFLUSH ? "RFLUSH" : > > + id == P9_RREADDIR ? "READDIR" : > > "<unknown>"; > > > > } > > > > @@ -348,6 +360,79 @@ static void v9fs_rwalk(P9Req *req, uint16_t *nwqid, > > v9fs_qid **wqid)> > > v9fs_req_free(req); > > > > } > > > > +/* size[4] Treaddir tag[2] fid[4] offset[8] count[4] */ > > +static P9Req *v9fs_treaddir(QVirtio9P *v9p, uint32_t fid, uint64_t > > offset, > > + uint32_t count, uint16_t tag) > > +{ > > + P9Req *req; > > + > > + req = v9fs_req_init(v9p, 4 + 8 + 4, P9_TREADDIR, tag); > > + v9fs_uint32_write(req, fid); > > + v9fs_uint64_write(req, offset); > > + v9fs_uint32_write(req, count); > > + v9fs_req_send(req); > > + return req; > > +} > > + > > +struct v9fs_dirent { > > + v9fs_qid qid; > > + uint64_t offset; > > + uint8_t type; > > + char *name; > > + struct v9fs_dirent *next; > > +}; > > + > > +/* size[4] Rreaddir tag[2] count[4] data[count] */ > > +static void v9fs_rreaddir(P9Req *req, uint32_t *count, uint32_t > > *nentries, > > + struct v9fs_dirent **entries) > > +{ > > + uint32_t sz; > > Even if this is a size indeed, the 9p spec uses the wording "count" and > so does the function signature. Please rename this variable to local_count. > Some other functions that return server originated data already use this > naming scheme.
I know, I did that intentionally. But I don't care for such code style details enough to start argueing, so I'll change it. > > > + struct v9fs_dirent *e = NULL; > > + uint16_t slen; > > + uint32_t n = 0; > > + > > + v9fs_req_recv(req, P9_RREADDIR); > > + v9fs_uint32_read(req, &sz); > > + > > + if (count) { > > + *count = sz; > > + } > > + > > + for (int32_t togo = (int32_t)sz; > > + togo >= 13 + 8 + 1 + 2; > > + togo -= 13 + 8 + 1 + 2 + slen, ++n) > > + { > > + if (!e) { > > + e = g_malloc(sizeof(struct v9fs_dirent)); > > + if (entries) > > ERROR: braces {} are necessary for all arms of this statement > #98: FILE: tests/virtio-9p-test.c:407: > + if (entries) > [...] Right, sorry I missed that for some reason. Best regards, Christian Schoenebeck