On Fri, 19 Jun 2020 12:50:11 +0200
Janosch Frank <fran...@linux.ibm.com> wrote:

> On 6/19/20 12:22 AM, Collin Walling wrote:
> > Rework the SCLP boundary check to account for different SCLP commands
> > (eventually) allowing different boundary sizes.
> > 
> > Move the length check code into a separate function, and introduce a
> > new function to determine the length of the read SCP data (i.e. the size
> > from the start of the struct to where the CPU entries should begin).
> > 
> > The format of read CPU info is unlikely to change in the future,
> > so we do not require a separate function to calculate its length.
> > 
> > Signed-off-by: Collin Walling <wall...@linux.ibm.com>  
> 
> Acked-by: Janosch Frank <fran...@linux.ibm.com>
> 
> > ---  
> [...]
> > +/*
> > + * The data length denotes the start of the struct to where the first
> > + * CPU entry is to be allocated. This value also denotes the offset_cpu
> > + * field.
> > + */
> > +static inline int get_read_scp_info_data_len(void)
> > +{
> > +    return offsetof(ReadInfo, entries);
> > +}
> > +
> >  /* Provide information about the configuration, CPUs and storage */
> >  static void read_SCP_info(SCLPDevice *sclp, SCCB *sccb)
> >  {
> > @@ -74,17 +112,16 @@ static void read_SCP_info(SCLPDevice *sclp, SCCB *sccb)
> >      int cpu_count;
> >      int rnsize, rnmax;
> >      IplParameterBlock *ipib = s390_ipl_get_iplb();
> > +    int data_len = get_read_scp_info_data_len();  
> 
> Does somebody have a better name than data_len at hand?

I could not come up with anything better, either :(

(...)

Reviewed-by: Cornelia Huck <coh...@redhat.com>

Attachment: pgpRSeQVOVfGM.pgp
Description: OpenPGP digital signature

Reply via email to