On 07/25/2011 04:52 AM, Avi Kivity wrote:
On 07/25/2011 12:48 PM, Peter Maydell wrote:
On 25 July 2011 10:32, Alexander Graf<ag...@suse.de> wrote:
> On 25.07.2011, at 10:51, Avi Kivity wrote:
>> qemu_malloc() is type-unsafe as it returns a void pointer. Introduce
>> QEMU_NEW() (and QEMU_NEWZ()), which return the correct type.
>
> What does this buy you over
>
> type *x = qemu_malloc(sizeof(type));
>
> ? I find the non-C++ version easier to read even.

Yeah, while we're writing in C we should just stick to the C-like
APIs, it's less confusing IMHO than wrapping it up in something else.

That argument can be used to block any change. You'll get used to it in
time. The question is, is the new interface better or not.

I assume Anthony's new object model stuff will have a "create me a
new foo object" API anyway, so QEMU_NEW() is possibly a bit of a
namespace grab.

Anthony's stuff is at a much higher level, hopefully he'll come back to
the ground one day.

The point of introducing glib was to address things like this. We need to start making heavier use of what it provides.

Regards,

Anthony Liguori



Reply via email to