Hi

On Thu, Sep 10, 2020 at 11:50 PM Eduardo Habkost <ehabk...@redhat.com>
wrote:

> Some chardev QOM cleanup patches had to be dropped from my queue
> due to build erros introduced by code movements across ifdef
> boundaries at char-parallel.c.  This series redo the changes from
> those patches, but the macro renames are now a little different:
>
> In this version I have decided to rename the type checking macros
> from *_CHARDEV to CHARDEV_* instead of renaming tye
> TYPE_CHARDEV_* constants to TYPE_*_CHARDEV, to make the
> identifiers actually match the QOM type name strings
> ("chardev-*").
>

Sounds reasonable to me, but it loses the matching with the
structure/object type name though.

- MuxChardev *d = MUX_CHARDEV(s);
+ MuxChardev *d = CHARDEV_MUX(s);

I have a preference for the first. Unless we rename all the chardev types
too...

Imho, the QOM type name is mostly an internal detail, the C type name is
dominant in the code.



> Eduardo Habkost (18):
>   chardev: Move PARALLEL_CHARDEV macro to common code
>   chardev: Move ParallelChardev typedef to common code
>   chardev: Use DECLARE_INSTANCE_CHECKER macro for PARALLEL_CHARDEV
>   chardev: Rename MOUSE_CHARDEV to CHARDEV_MSMOUSE
>   chardev: Rename BAUM_CHARDEV to CHARDEV_BRAILLE
>   chardev: Rename FD_CHARDEV to CHARDEV_FD
>   chardev: Rename MUX_CHARDEV to CHARDEV_MUX
>   chardev: Rename PARALLEL_CHARDEV to CHARDEV_PARALLEL
>   chardev: Rename PTY_CHARDEV to CHARDEV_PTY
>   chardev: Rename RINGBUF_CHARDEV to CHARDEV_RINGBUF
>   chardev: Rename SOCKET_CHARDEV to CHARDEV_SOCKET
>   chardev: Rename SPICE_CHARDEV to CHARDEV_SPICE
>   chardev: Rename TESTDEV_CHARDEV to CHARDEV_TESTDEV
>   chardev: Rename UDP_CHARDEV to CHARDEV_UDP
>   chardev: Rename VC_CHARDEV to CHARDEV_VC
>   chardev: Rename WCTABLET_CHARDEV to CHARDEV_WCTABLET
>   chardev: Rename WIN_CHARDEV to CHARDEV_WIN
>   chardev: Rename WIN_STDIO_CHARDEV to CHARDEV_WIN_STDIO
>
>  chardev/chardev-internal.h |  2 +-
>  include/chardev/char-fd.h  |  2 +-
>  include/chardev/char-win.h |  2 +-
>  include/chardev/spice.h    |  2 +-
>  chardev/baum.c             | 14 ++++----
>  chardev/char-fd.c          | 14 ++++----
>  chardev/char-fe.c          |  4 +--
>  chardev/char-mux.c         | 22 ++++++------
>  chardev/char-parallel.c    | 28 ++++++++--------
>  chardev/char-pipe.c        |  2 +-
>  chardev/char-pty.c         | 22 ++++++------
>  chardev/char-ringbuf.c     | 12 +++----
>  chardev/char-serial.c      |  2 +-
>  chardev/char-socket.c      | 68 +++++++++++++++++++-------------------
>  chardev/char-udp.c         | 14 ++++----
>  chardev/char-win-stdio.c   | 14 ++++----
>  chardev/char-win.c         | 14 ++++----
>  chardev/char.c             |  2 +-
>  chardev/msmouse.c          | 12 +++----
>  chardev/spice.c            | 16 ++++-----
>  chardev/testdev.c          |  4 +--
>  chardev/wctablet.c         | 12 +++----
>  ui/console.c               | 10 +++---
>  ui/gtk.c                   |  8 ++---
>  ui/spice-app.c             |  2 +-
>  25 files changed, 151 insertions(+), 153 deletions(-)
>
> --
> 2.26.2
>
>
>
>

-- 
Marc-André Lureau

Reply via email to