On 13/10/20 16:38, Claudio Fontana wrote:
> +void bdrv_bh_schedule_oneshot(AioContext *ctx, QEMUBHFunc *cb, void *opaque)
> +{
> +    if (replay_events_enabled()) {
> +        replay_bh_schedule_oneshot_event(ctx, cb, opaque);
> +    } else {
> +        aio_bh_schedule_oneshot(ctx, cb, opaque);
> +    }
> +}
> +
> +void bdrv_bh_schedule(QEMUBH *bh)
> +{
> +    if (replay_events_enabled()) {
> +        replay_bh_schedule_event(bh);
> +    } else {
> +        qemu_bh_schedule(bh);
> +    }
> +}

This is definitely better, but I'll defer to Kevin with respect to the
naming of the function; having a bdrv_* function that has nothing to do
with the block layer is still smelly of a sub-optimal API, and I'm not
sure why the API change belongs in the series.

Paolo


Reply via email to