On 10/21/20 12:21 PM, Alistair Francis wrote: >> mmuidx, you would use cpu_lduw_mmuidx_ra. I would also split the function >> into >> two, so that one performs HLVX.HU and the other HLVX.WU, so that you don't >> have >> to pass the size as a parameter. > > I'm not clear what you mean here.
target_ulong helper_hyp_x_load(CPURISCVState *env, target_ulong address, target_ulong attrs, target_ulong memop) should be split to target_ulong helper_hlvx_hu(CPURISCVState *env, target_ulong address) target_ulong helper_hlvx_hw(CPURISCVState *env, target_ulong address) (attrs is already unused?) so that memop is not required. r~