On 2020/11/11 3:02, Krish Sadhukhan wrote:

On 11/9/20 5:49 PM, Like Xu wrote:
Hi Krish,

On 2020/11/10 9:23, Krish Sadhukhan wrote:
@@ -1192,7 +1192,7 @@ void vmx_set_host_fs_gs(struct vmcs_host_state *host, u16 fs_sel, u16 gs_sel,
      }
  }
  -void vmx_prepare_switch_to_guest(struct kvm_vcpu *vcpu)
+void vmx_prepare_guest_switch(struct kvm_vcpu *vcpu)

What do you think of renaming it to

    void vmx_prepare_switch_for_guest(struct kvm_vcpu *vcpu);


In my opinion, it sounds a bit odd as we usually say, "switch to something". :-)

From that perspective, {svm|vmx}_prepare_switch_to_guest is probably the best name to keep.

Ah, I'm fine with the original one and thank you.




?

Thanks,
Like Xu

  {
      struct vcpu_vmx *vmx = to_vmx(vcpu);
      struct vmcs_host_state *host_state;

@@ -311,7 +311,7 @@ void vmx_vcpu_load_vmcs(struct kvm_vcpu *vcpu, int cpu,
  int allocate_vpid(void);
  void free_vpid(int vpid);
  void vmx_set_constant_host_state(struct vcpu_vmx *vmx);
-void vmx_prepare_switch_to_guest(struct kvm_vcpu *vcpu);
+void vmx_prepare_guest_switch(struct kvm_vcpu *vcpu);
  void vmx_set_host_fs_gs(struct vmcs_host_state *host, u16 fs_sel, u16 gs_sel,
              unsigned long fs_base, unsigned long gs_base);
  int vmx_get_cpl(struct kvm_vcpu *vcpu);



Reply via email to