"Michael S. Tsirkin" <m...@redhat.com> writes: >> +#include "qemu/cutils.h" >> + >> +#define ACPI_BUILD_APPNAME6 "BOCHS " >> +#define ACPI_BUILD_APPNAME8 "BXPC " > > A single user for each of these now ... drop the defines? >
Unfortunately ACPI_BUILD_APPNAME8 is still used in build_header() in aml-build.c, and to me it didn't look nice for one to have a define and the other not, but if you prefer with only ACPI_BUILD_APPNAME8 as a define, I can do the change. >> +#define ACPI_INIT_DEFAULT_BUILD_OEM(__bld_oem) do { \ >> + ACPI_INIT_BUILD_OEM(__bld_oem, \ >> + ACPI_BUILD_APPNAME6, ACPI_BUILD_APPNAME8); \ >> +} while (0) > > OK but ... why are these macros? Won't inline functions > work just as well with more type safety? > Didn't know what was the attitude in this project to inlined functions in headers and went with macros. I will change to inlined functions.