On Tue, Aug 24, 2021 at 11:27:18AM -0300, Luis Pires wrote: > From: Bruno Larsen <bruno.lar...@eldorado.org.br> > > Move REQUIRE_ALTIVEC to translate.c and rename it to REQUIRE_VECTOR. > > Signed-off-by: Bruno Larsen <bruno.lar...@eldorado.org.br> > Signed-off-by: Matheus Ferst <matheus.fe...@eldorado.org.br> > Signed-off-by: Fernando Valle <fernando.va...@eldorado.org.br> > Signed-off-by: Luis Pires <luis.pi...@eldorado.org.br>
Reviewed-by: David Gibson <da...@gibson.dropbear.id.au> > --- > target/ppc/translate.c | 8 ++++++++ > target/ppc/translate/vector-impl.c.inc | 10 +--------- > 2 files changed, 9 insertions(+), 9 deletions(-) > > diff --git a/target/ppc/translate.c b/target/ppc/translate.c > index 171b216e17..4749ecdaa9 100644 > --- a/target/ppc/translate.c > +++ b/target/ppc/translate.c > @@ -7453,6 +7453,14 @@ static int times_4(DisasContext *ctx, int x) > # define REQUIRE_64BIT(CTX) REQUIRE_INSNS_FLAGS(CTX, 64B) > #endif > > +#define REQUIRE_VECTOR(CTX) \ > + do { \ > + if (unlikely(!(CTX)->altivec_enabled)) { \ > + gen_exception((CTX), POWERPC_EXCP_VPU); \ > + return true; \ > + } \ > + } while (0) > + > /* > * Helpers for implementing sets of trans_* functions. > * Defer the implementation of NAME to FUNC, with optional extra arguments. > diff --git a/target/ppc/translate/vector-impl.c.inc > b/target/ppc/translate/vector-impl.c.inc > index 117ce9b137..197e903337 100644 > --- a/target/ppc/translate/vector-impl.c.inc > +++ b/target/ppc/translate/vector-impl.c.inc > @@ -17,20 +17,12 @@ > * License along with this library; if not, see > <http://www.gnu.org/licenses/>. > */ > > -#define REQUIRE_ALTIVEC(CTX) \ > - do { \ > - if (unlikely(!(CTX)->altivec_enabled)) { \ > - gen_exception((CTX), POWERPC_EXCP_VPU); \ > - return true; \ > - } \ > - } while (0) > - > static bool trans_VCFUGED(DisasContext *ctx, arg_VX *a) > { > TCGv_i64 tgt, src, mask; > > REQUIRE_INSNS_FLAGS2(ctx, ISA310); > - REQUIRE_ALTIVEC(ctx); > + REQUIRE_VECTOR(ctx); > > tgt = tcg_temp_new_i64(); > src = tcg_temp_new_i64(); -- David Gibson | I'll have my music baroque, and my code david AT gibson.dropbear.id.au | minimalist, thank you. NOT _the_ _other_ | _way_ _around_! http://www.ozlabs.org/~dgibson
signature.asc
Description: PGP signature