On 25/8/22 17:07, Peter Maydell wrote:
There's only one place in configure where we use `...` to execute a
command and capture the result.  Switch to $() to match the rest of
the script. This silences a shellcheck warning.

Signed-off-by: Peter Maydell <peter.mayd...@linaro.org>
---
  configure | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/configure b/configure
index d5b6546ae81..5c1992d5bce 100755
--- a/configure
+++ b/configure
@@ -2317,7 +2317,7 @@ LINKS="$LINKS python"
  LINKS="$LINKS contrib/plugins/Makefile "
  for f in $LINKS ; do
      if [ -e "$source_path/$f" ]; then
-        mkdir -p `dirname ./$f`
+        mkdir -p "$(dirname ./"$f")"

Nitpicking, easier to read as "$(dirname ./${f})"

Reviewed-by: Philippe Mathieu-Daudé <f4...@amsat.org>

          symlink "$source_path/$f" "$f"
      fi
  done


Reply via email to