On Mon, Jan 02, 2012 at 07:00:30PM +0100, Paolo Bonzini wrote:
>  void notifier_list_add(NotifierList *list, Notifier *notifier)
>  {
> -    QTAILQ_INSERT_HEAD(&list->notifiers, notifier, node);
> +    QLIST_INSERT_HEAD(&list->notifiers, notifier, node);
>  }
>  
> -void notifier_list_remove(NotifierList *list, Notifier *notifier)
> +void notifier_remove(Notifier *notifier)

Why introduce this asymmetry with notifier_list_add() and
notifier_remove()?  Please make the function names consistent.

Stefan

Reply via email to