-------- Original Message --------
From: Philippe Mathieu-Daudé [mailto:phi...@linaro.org]> diff --git a/hw/timer/imx_epit.c b/hw/timer/imx_epit.c> index a79f58c963..37b04a1b53 100644 --- a/hw/timer/imx_epit.c +++ b/hw/timer/imx_epit.c @@ -77,23 +77,25 @@ static void imx_epit_update_int(IMXEPITState *s) * Must be called from within a ptimer_transaction_begin/commit block * for both s->timer_cmp and s->timer_reload. */ -static void imx_epit_set_freq(IMXEPITState *s) +static uint32_t imx_epit_set_freq(IMXEPITState *s) Maybe rename as imx_epit_get_freq() or simply imx_epit_freq(),
There will be an update of the whole patchset, so I will change the name to imx_epit_freq(). That makes the name and signature in sync. Note that the next commit in this patchset does more refactoring anyway, so this is just a intermediate change that is not really visible. Axel