On 09.01.23 15:39, David Hildenbrand wrote:
On 05.01.23 18:18, Peter Xu wrote:
On Thu, Dec 22, 2022 at 12:02:12PM +0100, David Hildenbrand wrote:
+bool migration_incoming_postcopy_listening(void)
+{
+    PostcopyState ps = postcopy_state_get();
+
+    return ps >= POSTCOPY_INCOMING_LISTENING && ps < POSTCOPY_INCOMING_END;
+}

This name is misleading, IMHO.

The code means "we passed listening phase" but the name implies "we're
listening".  We can add the "incoming" into that if we want, though.


Let me call that migration_incoming_postcopy_running(). Thanks!


... which is also misleading. Let me just drop the sanity check and this function.

--
Thanks,

David / dhildenb


Reply via email to