On 3/14/23 9:53 AM, Fan Ni wrote:
Replace the magic number 32 with CXL_RAS_ERR_HEADER_NUM for better code
readability and maintainability.

Signed-off-by: Fan Ni <fan...@samsung.com>
Reviewed-by: Dave Jiang <dave.ji...@intel.com>

---
  include/hw/cxl/cxl_device.h | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/hw/cxl/cxl_device.h b/include/hw/cxl/cxl_device.h
index d589f78202..34fde62eac 100644
--- a/include/hw/cxl/cxl_device.h
+++ b/include/hw/cxl/cxl_device.h
@@ -235,7 +235,7 @@ REG64(CXL_MEM_DEV_STS, 0)
  typedef struct CXLError {
      QTAILQ_ENTRY(CXLError) node;
      int type; /* Error code as per FE definition */
-    uint32_t header[32];
+    uint32_t header[CXL_RAS_ERR_HEADER_NUM];
  } CXLError;
typedef QTAILQ_HEAD(, CXLError) CXLErrorList;

Reply via email to