Hi Eric, On Mon, Mar 20, 2023 at 05:05:31PM +0100, Eric Auger wrote: > > + /* > > + * TLB lookup looks for granule and input size for a translation stage, > > + * as only one stage is supported right now, choose the right values > > + * from the configuration. > > + */ > > + page_mask = (1ULL << granule_sz) - 1; > > aligned_addr = addr & ~page_mask; > > > > - cached_entry = smmu_iotlb_lookup(bs, cfg, tt, aligned_addr); > > + SMMUTransTableInfo temp = { > Move the declaration at the top. Also rename temp into tt to be more > explicit about what it is? I will move it to the top and remove granule_sz and tsz and just assign values to this struct. There is a pointer already called tt, I can call it tt_combined as ideally this will hold the combined attributes for the TLB lookup.
Thanks, Mostafa