On 4/7/23 00:02, BALATON Zoltan wrote:
It is more readable to wrap the complex call to ppc_dcr_register in a
macro when needed repeatedly.
Signed-off-by: BALATON Zoltan <bala...@eik.bme.hu>
---
hw/ppc/ppc440_uc.c | 76 +++++++++++++++++-----------------------------
1 file changed, 28 insertions(+), 48 deletions(-)
+#define PPC440_PCIE_DCR(s, dcrn) \
+ ppc_dcr_register(&(s)->cpu->env, (s)->dcrn_base + (dcrn), s, \
'(s), \'
+ &dcr_read_pcie, &dcr_write_pcie)
+
+
Reviewed-by: Philippe Mathieu-Daudé <phi...@linaro.org>