`Hi Stuti,
Your problem is that if you want to have more than one command on a
single line, you must separate them with a semicolon.

j <- function() {
 if(!exists ("a")){
 a <- 1
 } else{
 a <- a+1
}; print(a)}

The above will work, but is usually considered bad form. What follows
is usually easier to read and avoids that sort of error.

j <- function() {
 if(!exists ("a")) {
 a <- 1
 } else {
 a <- a+1
 }
 print(a)
}

Notice how the opening and closing braces ({}) are "lined up" to make
the code easier to read. Most people recommend using at least two
spaces indent, but far be it from me to demand conformity in these
matters.

Jim


On Thu, Nov 24, 2016 at 6:43 PM, Stuti Verma <stuti.verma...@gmail.com> wrote:
>> j <- function() {
> + if(!exists ("a")){
> + a <- 1
> + } else{
> + a <- a+1
> + } print(a)}
>
> Error: unexpected symbol in:
> "a <- a+1
> } print"
>
>> j <- function() {
> + if(!exists ("a")){
> + a <- 1
> + } else{
> + a <- a+1
> + } print("a")}
>
> Error: unexpected symbol in:
> "a <- a+1
> } print"
>
>         [[alternative HTML version deleted]]
>
> ______________________________________________
> R-help@r-project.org mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

______________________________________________
R-help@r-project.org mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.

Reply via email to