-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/17303/#review33465
-----------------------------------------------------------



src/main/java/org/apache/aurora/scheduler/base/Jobs.java
<https://reviews.apache.org/r/17303/#comment62899>

    This uses time so it should take a Clock instance for testing.



src/main/java/org/apache/aurora/scheduler/base/Tasks.java
<https://reviews.apache.org/r/17303/#comment62900>

    Unclear from name what this variable is for. Is this supposed to be 
ScheduleStatus.values()?



src/main/java/org/apache/aurora/scheduler/base/Tasks.java
<https://reviews.apache.org/r/17303/#comment62902>

    Why the indirection? Why not call this latestActiveTask?



src/main/java/org/apache/aurora/scheduler/base/Tasks.java
<https://reviews.apache.org/r/17303/#comment62904>

    explicit orderings will throw RuntimeExceptions if they encounter a value 
not in the explicit set. It doesn't seem to me that STATUSES is exhaustive and 
I don't see test coverage to guarantee that in the future.



src/test/java/org/apache/aurora/scheduler/base/TaskUtil.java
<https://reviews.apache.org/r/17303/#comment62906>

    How would you feel about naming this TaskFixtures or TaskTestUtil?


- Kevin Sweeney


On Jan. 23, 2014, 11:13 p.m., Suman Karumuri wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/17303/
> -----------------------------------------------------------
> 
> (Updated Jan. 23, 2014, 11:13 p.m.)
> 
> 
> Review request for Aurora, Kevin Sweeney and Bill Farner.
> 
> 
> Bugs: AURORA-64
>     https://issues.apache.org/jira/browse/AURORA-64
> 
> 
> Repository: aurora
> 
> 
> Description
> -------
> 
> Added task stats to getJobs API so it can be used by the role page in the UI.
> Refactored code from SchedulerzRole and SchedulerzRoleTest into relevant 
> classes so it can be used by the UI and the thrift API.
> Added tests for new code.
> Moved populateJobConfig call into ReadOnlyScheduler.
> 
> 
> Diffs
> -----
> 
>   src/main/java/org/apache/aurora/scheduler/base/Jobs.java PRE-CREATION 
>   src/main/java/org/apache/aurora/scheduler/base/Tasks.java 
> 06a19d80483b6949c9851b5d38fe34ac712aa75e 
>   src/main/java/org/apache/aurora/scheduler/http/SchedulerzRole.java 
> b0caca73b46fba928fb718ab45a608dad4685a2f 
>   
> src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java
>  cf9099f307efa23ca34634e3512d9cdbebfa82f2 
>   src/main/thrift/org/apache/aurora/gen/api.thrift 
> 74010379baa2e47cefc228943f766c7b3a8b0d97 
>   src/test/java/org/apache/aurora/scheduler/base/JobsTest.java PRE-CREATION 
>   src/test/java/org/apache/aurora/scheduler/base/TaskUtil.java PRE-CREATION 
>   src/test/java/org/apache/aurora/scheduler/http/SchedulerzRoleTest.java 
> 912be189583419e7201e45650d18cd24a6a5a35b 
>   
> src/test/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterfaceTest.java
>  6cefdfad469a9b69a5291ad46be1df14b443472e 
>   src/test/resources/org/apache/aurora/gen/api.thrift.md5 
> 42fdca2759f15d007bee058485c237268c57597a 
> 
> Diff: https://reviews.apache.org/r/17303/diff/
> 
> 
> Testing
> -------
> 
> gradle clean build
> gradle run to test local UI.
> 
> 
> Thanks,
> 
> Suman Karumuri
> 
>

Reply via email to