Dimitris Tsirogiannis has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/8851 )

Change subject: IMPALA-3193: Show table's comment on show tables
......................................................................


Patch Set 15:

(2 comments)

http://gerrit.cloudera.org:8080/#/c/8851/15/fe/src/test/java/org/apache/impala/testutil/ImpaladTestCatalog.java
File fe/src/test/java/org/apache/impala/testutil/ImpaladTestCatalog.java:

http://gerrit.cloudera.org:8080/#/c/8851/15/fe/src/test/java/org/apache/impala/testutil/ImpaladTestCatalog.java@81
PS15, Line 81: getLoadedTable
I think this function should be called loadAndAddTable. The current name 
implies that you return a table that is already loaded but this function is the 
one doing the load.


http://gerrit.cloudera.org:8080/#/c/8851/15/fe/src/test/java/org/apache/impala/testutil/ImpaladTestCatalog.java@107
PS15, Line 107: /**
              :    * Overrides ImpaladCatalog.getTables to load the table 
metadata if it is missing.
              :    */
              :   @Override
              :   public List<Table> getTables(String dbName, PatternMatcher 
matcher)
              :       throws DatabaseNotFoundException {
              :     List<Table> tables = super.getTables(dbName, matcher);
              :
              :     // The table was not yet loaded. Load it in to the catalog 
and try getTable()
              :     // again.
              :     for (int i = 0; i < tables.size(); ++i) {
              :       Table table = tables.get(i);
              :       // Table doesn't exist or is already loaded. Just return 
it.
              :       if (table != null && !table.isLoaded()) {
              :         try {
              :           tables.set(i, getLoadedTable(dbName, 
table.getName()));
              :         } catch (CatalogException e) {
              :           LOG.error(String.format("Error loading table: %s.%s", 
dbName, table.getName()),
              :               e);
              :         }
              :       }
              :     }
              :     return tables;
              :   }
> During JUnit test, it should be called at "impaladCatalog_.get().getTables(
Good point. Thanks for the explanation.



--
To view, visit http://gerrit.cloudera.org:8080/8851
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: Impala-ASF
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I44f814af05db6f3c027718ade9f474f8b8153bcd
Gerrit-Change-Number: 8851
Gerrit-PatchSet: 15
Gerrit-Owner: Kim Jin Chul <jinc...@gmail.com>
Gerrit-Reviewer: Dimitris Tsirogiannis <dtsirogian...@cloudera.com>
Gerrit-Reviewer: Impala Public Jenkins
Gerrit-Reviewer: Kim Jin Chul <jinc...@gmail.com>
Gerrit-Comment-Date: Mon, 12 Feb 2018 23:26:09 +0000
Gerrit-HasComments: Yes

Reply via email to