Todd Lipcon has posted comments on this change.

Change subject: [KuduScanBatch::const_iterator] a minor clean-up
......................................................................


Patch Set 1:

(3 comments)

http://gerrit.cloudera.org:8080/#/c/3834/1/src/kudu/client/scan_batch.h
File src/kudu/client/scan_batch.h:

Line 208:               return (idx_ == other.idx_) && (batch_ == other.batch_);
nit: tabs


Line 211:               return !this->operator==(other);
is there a difference between this and the more obvious-looking "!(*this == 
other)"?


Line 221:   const KuduScanBatch* batch_;
maybe we should make this const (const KuduScanBatch* const batch_;) to 
encourage the optimizer to be able to inline out the equality checks?


-- 
To view, visit http://gerrit.cloudera.org:8080/3834
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I3eeba46e5bc45c9dd7b96abad60173381d6c3e39
Gerrit-PatchSet: 1
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Alexey Serbin <aser...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <t...@apache.org>
Gerrit-HasComments: Yes

Reply via email to