Todd Lipcon has submitted this change and it was merged.

Change subject: bshuf_block: some code cleanup
......................................................................


bshuf_block: some code cleanup

* Some typo/grammar fixes/reformatting in comments.
* Rename kMaxHeaderSize to kHeaderSize since the header is fixed-length.
* Adds a private cell_ptr() function instead of error prone indexing
  with multiplication into the data_ buffer.
* Remove an unnecessarily UINT32 specialization
* Fix some C-style casts and unnecessary type punning in favor of
  memcpy()
* Cleaned up padding code to use KUDU_ALIGN_UP

This also adds a TODO for a bug with GetLastKey: we are mistakenly
indexing into data_[count - 1] instead of data_[(count - 1) *
size_of_type] which causes incorrect results. The fix for this is in the
following commit.

Change-Id: I6857f8096319072eb09be097adea99c45735e0a6
Reviewed-on: http://gerrit.cloudera.org:8080/5193
Reviewed-by: Adar Dembo <a...@cloudera.com>
Tested-by: Kudu Jenkins
---
M src/kudu/cfile/bshuf_block.cc
M src/kudu/cfile/bshuf_block.h
2 files changed, 88 insertions(+), 79 deletions(-)

Approvals:
  Adar Dembo: Looks good to me, approved
  Kudu Jenkins: Verified



-- 
To view, visit http://gerrit.cloudera.org:8080/5193
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I6857f8096319072eb09be097adea99c45735e0a6
Gerrit-PatchSet: 8
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Todd Lipcon <t...@apache.org>
Gerrit-Reviewer: Adar Dembo <a...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <aser...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <dral...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon <t...@apache.org>

Reply via email to