Dinesh Bhat has posted comments on this change.

Change subject: KUDU-1776: Fix "kudu remote_replica copy" connecting to 
wildcard address
......................................................................


Patch Set 6:

(9 comments)

http://gerrit.cloudera.org:8080/#/c/5378/6/src/kudu/integration-tests/external_mini_cluster.h
File src/kudu/integration-tests/external_mini_cluster.h:

PS6, Line 82: as binding ip 
> nit: "as the IP to bind to"
Done


PS6, Line 109: UNIQUE_LOOPBACK
> UNIQUE_LOOPBACK on Linux, LOOPBACK on macOS.
Done


Line 115:   BindMode bind_mode_;
> This is a struct, so per the style guide this member shouldn't have a taili
good catch, done.


Line 419:   virtual void set_rpc_bind_address(std::string address) = 0;
> Why make this a virtual public method when it is only ever called by constr
Good point,done.


Line 420:   virtual const std::string& get_rpc_bind_address() const = 0;
> Why make this a virtual public method? Why not just a protected variable?
Done


Line 503:   virtual void set_rpc_bind_address(std::string host) override {
> Why override these methods when they are verbatim the same for both impleme
yeah, defeats the the purpose altogether, i moved them to base class.


Line 536:   virtual void set_rpc_bind_address(std::string host) override {
> And these...
Done


http://gerrit.cloudera.org:8080/#/c/5378/6/src/kudu/tools/kudu-tool-test.cc
File src/kudu/tools/kudu-tool-test.cc:

Line 232:   ExternalMiniClusterOptions opts_;
> nit: maybe name this cluster_opts_
Done


Line 964:   opts_.bind_mode_ = ExternalMiniClusterOptions::WILDCARD;
> Please add a comment noting that this line is important in order to provide
Done


-- 
To view, visit http://gerrit.cloudera.org:8080/5378
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ie5d0a37b39a3774caab5b5d8dba3d9750bf5f21f
Gerrit-PatchSet: 6
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Dinesh Bhat <din...@cloudera.com>
Gerrit-Reviewer: Dinesh Bhat <din...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Mike Percy <mpe...@apache.org>
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon <t...@apache.org>
Gerrit-HasComments: Yes

Reply via email to