Todd Lipcon has posted comments on this change.

Change subject: Fix bug in incorrect response rebuilding on tablet bootstrap
......................................................................


Patch Set 4:

(8 comments)

http://gerrit.cloudera.org:8080/#/c/5489/4/src/kudu/tablet/row_op.cc
File src/kudu/tablet/row_op.cc:

Line 56:   DCHECK(!this->result) << this->result->DebugString();
think we should leave this with SecureDebugString


http://gerrit.cloudera.org:8080/#/c/5489/4/src/kudu/tablet/tablet_bootstrap.cc
File src/kudu/tablet/tablet_bootstrap.cc:

Line 251:   // Plays operations, skipping those that have already been flushed.
can you clarify how it knows what is already flushed here?


PS4, Line 256: result
update


Line 259:                                              TxResultPB* new_result,
update docs to explain what it's filling in in new_result


PS4, Line 1440: ShortDebugString
should use Secure form


PS4, Line 1459:     const OperationResultPB& new_op_result = 
new_result->ops(curr_op_idx);
this is only used down below inside the if block on L1491, right? maybe move 
the decl there?


PS4, Line 1491: flushed
should we rename this PB field to 'skip_on_replay'? I think it would be more 
accurate as to its purpose


PS4, Line 1519: already_flushed
also should maybe rename this field to "skip_replay"?

One thought (not sure if it would work): given that if previously_failed is 
true, then this would also always be true, could we combine the two booleans 
into an enum of NEEDS_REPLAY, SKIP_PREVIOUSLY_FAILED, and 
SKIP_PREVIOUSLY_FLUSHED or something?


-- 
To view, visit http://gerrit.cloudera.org:8080/5489
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I1219ed5f7835e93cd7f3b128cedd650fc3384482
Gerrit-PatchSet: 4
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <davidral...@gmail.com>
Gerrit-Reviewer: Jean-Daniel Cryans <jdcry...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Mike Percy <mpe...@apache.org>
Gerrit-Reviewer: Todd Lipcon <t...@apache.org>
Gerrit-HasComments: Yes

Reply via email to