Alexey Serbin has posted comments on this change.

Change subject: minicluster: facilitate creating multidir clusters
......................................................................


Patch Set 9:

(9 comments)

http://gerrit.cloudera.org:8080/#/c/6845/9/src/kudu/integration-tests/external_mini_cluster.cc
File src/kudu/integration-tests/external_mini_cluster.cc:

PS9, Line 255: dir_nums
nit: not sure that's the best name for the parameter

what about 'dir_suffix' or alike?


http://gerrit.cloudera.org:8080/#/c/6845/9/src/kudu/integration-tests/external_mini_cluster.h
File src/kudu/integration-tests/external_mini_cluster.h:

PS9, Line 26: #include <sys/types.h>
This is from the system C headers, this should come the very first in this file.


http://gerrit.cloudera.org:8080/#/c/6845/9/src/kudu/integration-tests/multidisk-cluster-itest.cc
File src/kudu/integration-tests/multidisk-cluster-itest.cc:

Line 21: 
nit: consider adding

#include <gtest/gtest.h>


PS9, Line 26: #include "kudu/integration-tests/test_workload.h"
I don't think it's necessary.


PS9, Line 44: TabletServerIntegrationTestBase
Why not just ExternalMiniClusterITestBase ?  Is there anything   specific you 
want to bring from tablet-server specific test?


PS9, Line 46: MultiDiskClusterITest() {}
I think you can drop this empty constructor -- it will be automatically 
generated for you by the compiler.


PS9, Line 93: CHECK_GT
why not ASSERT_GT()?

What about just

  ASSERT_FALSE(tablet_replicas_.empty());


PS9, Line 129: ASSERT_GT(1, num_dirs_added_to);
I'm confused by the combination of the comment and this assert: if I'm not 
mistaken, the latter is equivalent to ASSERT_TRUE(1 > num_dirs_added_to) and 
the former contradicts with that.

Consider either clarifying on the comment or updating the assert condition.  Or 
I'm missing something :)


http://gerrit.cloudera.org:8080/#/c/6845/9/src/kudu/util/path_util.cc
File src/kudu/util/path_util.cc:

PS9, Line 58: string ListPaths(const vector<string>& paths) {
            :   if (paths.empty()) return "";
            :   std::stringstream ss;
            :   for (int path_num = 0; path_num < paths.size(); path_num++) {
            :     if (path_num != 0) {
            :       ss << ",";
            :     }
            :     ss << paths[path_num];
            :   }
            :   return ss.str();
            : }
It seems using JoinStrings(paths, ",") could be a better fit here.  If so, does 
it make sense to bring this new function at all?

If switching to JoinStrings, don't forget to remove the <sstream> include.


-- 
To view, visit http://gerrit.cloudera.org:8080/6845
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Id2f5def6980ad394c8558ad97ba830f1b0257332
Gerrit-PatchSet: 9
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Andrew Wong <aw...@cloudera.com>
Gerrit-Reviewer: Adar Dembo <a...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <aser...@cloudera.com>
Gerrit-Reviewer: Andrew Wong <aw...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <davidral...@gmail.com>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Mike Percy <mpe...@apache.org>
Gerrit-Reviewer: Tidy Bot
Gerrit-HasComments: Yes

Reply via email to