Hao Hao has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/8041 )

Change subject: KUDU-2055 [part 2]: Add util to construct sorted disjoint 
interval list
......................................................................


Patch Set 6:

(4 comments)

http://gerrit.cloudera.org:8080/#/c/8041/5/src/kudu/util/sorted_disjoint_interval_list.h
File src/kudu/util/sorted_disjoint_interval_list.h:

http://gerrit.cloudera.org:8080/#/c/8041/5/src/kudu/util/sorted_disjoint_interval_list.h@73
PS5, Line 73: // interval.
> Is auto possible here? If so, we can avoid the IntervalIterator typedef.
It seems not possible to use auto here. Throws 'requires an initializer' error.

Yes, I agree with you 'start', 'end' may not be a good name here. May be 
'head', 'tail' are better. Will update.


http://gerrit.cloudera.org:8080/#/c/8041/5/src/kudu/util/sorted_disjoint_interval_list.h@81
PS5, Line 81:       if (tail->second > head->second)  head->second = 
std::move(tail->second);
> In both branches, is there a way to move the point values instead of copyin
Done


http://gerrit.cloudera.org:8080/#/c/8041/5/src/kudu/util/sorted_disjoint_interval_list.h@82
PS5, Line 82:       ++tail;
> I think this branch should just be moving *end into *(start + 1), so I don'
Done. Yeah, we should only move if there is a gap between the two.


http://gerrit.cloudera.org:8080/#/c/8041/5/src/kudu/util/sorted_disjoint_interval_list.h@94
PS5, Line 94:   // Truncate the rest useless elements, if any.
> This might be better as
Done



--
To view, visit http://gerrit.cloudera.org:8080/8041
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I61a813c047be4882f246eaf404598e7e18fcac87
Gerrit-Change-Number: 8041
Gerrit-PatchSet: 6
Gerrit-Owner: Hao Hao <hao....@cloudera.com>
Gerrit-Reviewer: Adar Dembo <a...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <aser...@cloudera.com>
Gerrit-Reviewer: Andrew Wong <aw...@cloudera.com>
Gerrit-Reviewer: Dan Burkert <danburk...@apache.org>
Gerrit-Reviewer: David Ribeiro Alves <davidral...@gmail.com>
Gerrit-Reviewer: Hao Hao <hao....@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon <t...@apache.org>
Gerrit-Comment-Date: Sun, 24 Sep 2017 20:50:48 +0000
Gerrit-HasComments: Yes

Reply via email to