Hannah Nguyen has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/14177 )

Change subject: KUDU-2780: create thread for auto-rebalancing
......................................................................


Patch Set 12:

(9 comments)

http://gerrit.cloudera.org:8080/#/c/14177/12/src/kudu/master/auto_rebalancer.cc
File src/kudu/master/auto_rebalancer.cc:

http://gerrit.cloudera.org:8080/#/c/14177/12/src/kudu/master/auto_rebalancer.cc@103
PS12, Line 103: using std::multimap;
> warning: using decl 'multimap' is unused [misc-unused-using-decls]
Done


http://gerrit.cloudera.org:8080/#/c/14177/12/src/kudu/master/auto_rebalancer.cc@104
PS12, Line 104: using std::random_device;
> warning: using decl 'random_device' is unused [misc-unused-using-decls]
Done


http://gerrit.cloudera.org:8080/#/c/14177/12/src/kudu/master/auto_rebalancer.cc@105
PS12, Line 105: using std::set;
> warning: using decl 'set' is unused [misc-unused-using-decls]
Done


http://gerrit.cloudera.org:8080/#/c/14177/12/src/kudu/master/auto_rebalancer.cc@109
PS12, Line 109: using std::transform;
> warning: using decl 'transform' is unused [misc-unused-using-decls]
Done


http://gerrit.cloudera.org:8080/#/c/14177/12/src/kudu/master/auto_rebalancer.cc@110
PS12, Line 110: using std::unique_ptr;
> warning: using decl 'unique_ptr' is unused [misc-unused-using-decls]
Done


http://gerrit.cloudera.org:8080/#/c/14177/12/src/kudu/master/auto_rebalancer.cc@168
PS12, Line 168:       FLAGS_auto_rebalancing_load_imbalance_threshold))),
> warning: narrowing conversion from 'double' to 'bool' [bugprone-narrowing-c
Done


http://gerrit.cloudera.org:8080/#/c/14177/12/src/kudu/master/auto_rebalancer.cc@363
PS12, Line 363:   int max_moves = FLAGS_auto_rebalancing_max_moves_per_server * 
num_tservers;
> warning: narrowing conversion from 'unsigned int' to signed type 'int' is i
Done


http://gerrit.cloudera.org:8080/#/c/14177/12/src/kudu/master/auto_rebalancer.cc@383
PS12, Line 383:     rebalancer_.FindReplicas(move, raw_info, &tablet_ids);
> warning: static member accessed through instance [readability-static-access
Done


http://gerrit.cloudera.org:8080/#/c/14177/12/src/kudu/master/auto_rebalancer.cc@701
PS12, Line 701:   while (moves_to_remove.size() != 0) {
> warning: the 'empty' method should be used to check for emptiness instead o
Done



--
To view, visit http://gerrit.cloudera.org:8080/14177
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Ifca25d1063c07047cf2123e6792b3c7395be20e4
Gerrit-Change-Number: 14177
Gerrit-PatchSet: 12
Gerrit-Owner: Hannah Nguyen <hannah.ngu...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <aser...@cloudera.com>
Gerrit-Reviewer: Andrew Wong <aw...@cloudera.com>
Gerrit-Reviewer: Hannah Nguyen <hannah.ngu...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Reviewer: Tidy Bot (241)
Gerrit-Comment-Date: Mon, 03 Feb 2020 19:48:39 +0000
Gerrit-HasComments: Yes

Reply via email to